Videokarma.org

Go Back   Videokarma.org TV - Video - Vintage Television & Radio Forums > Solid State CRT Televisions

We appreciate your help

in keeping this site going.
Reply
 
Thread Tools Display Modes
  #1  
Old 11-18-2018, 02:15 PM
Dreamsbeard's Avatar
Dreamsbeard Dreamsbeard is offline
VideoKarma Member
 
Join Date: Jul 2012
Location: Quebec city
Posts: 255
Mitsubishi CK2584C

Hi there folks,

Its been a while since my last post, but since the arrival of my second child I had about 5 mins of free time per day...so the television hobby had to be put on the backburner.

Anyway, I picked up this nice Mitsubishi this week. I had another one of those about a few years ago but decided to get rid of it even if the picture quality was AMAZING, and I always regreted it (reason I junked it was that the cabinet was a particle board fest) ! Well this one is even better since it gots composite inputs and outputs for an outside sound system setup.

Side by side comparison with a same year RCA colortrack with coax and the mitsu on composite is night and day. the Mitsu almost look HD in comparison.

But of course theres a catch, I have almost no sound. There is a switch at the back that turn the speakers of the TV on or off , and when i press ON I am greated by a hummmm and very faint sound comming from the speaker.

Anyone would like to give me an easy fix for this...please? haha

Thanks!

Edit : BTW I forgot to mention that there is a whole dedicated audio amplifier in the cabinet. more picture comming , but you can already see the big power transformer on the left of the first picture.
Attached Images
File Type: jpg 20181116_202357_resized.jpg (96.9 KB, 27 views)
File Type: jpg 20181116_202418_resized.jpg (37.6 KB, 17 views)
File Type: jpg 20181116_202904_resized.jpg (69.8 KB, 32 views)

Last edited by Dreamsbeard; 11-18-2018 at 09:18 PM.
Reply With Quote
  #2  
Old 11-18-2018, 07:06 PM
zeno zeno is offline
VideoKarma Member
 
Join Date: Mar 2013
Location: New Hampshire
Posts: 3,198
Probably not an quick fix but you can narrow things down..

There is probably a line out for the audio. Its low level & you can
hook it into a stereo etc & see if it sounds OK through the stereo. .
If the hum is always on the TV speakers even with the volume all the
way down its usually filter caps. See what happens & let us know.

This set is worth saving. The blue CRT face was used on all sized sets
& gave a great picture. IIRC they called it "Diamond Vision"
Latter MGA's were OK but nothing special.These were built better & with nothing left out.

Au revoir mon ami
Zeno
LFOD !
Reply With Quote
  #3  
Old 11-18-2018, 09:18 PM
Dreamsbeard's Avatar
Dreamsbeard Dreamsbeard is offline
VideoKarma Member
 
Join Date: Jul 2012
Location: Quebec city
Posts: 255
Hi Zeno,

Yes , the line out with the red and white composite wire through an external amp works fine (one channel is a bit muffled but its marginal).

When you say filter cap, are you talking about the TV chassis one or those on the AMp section? (see attached picture)

Merci Zeno!
Attached Images
File Type: jpg 20181118_210729.jpg (114.3 KB, 23 views)
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 07:33 PM.



Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
ęCopyright 2012 VideoKarma.org, All rights reserved.