View Full Version : CTC 39 Great picture, but slightly low HV


wabr101
05-12-2016, 12:20 AM
I replaced several weak tubes and put in a new 6En$ regulator, 3A3C Rectifier, and new 6CG7/6FQ7 drive tube. 6ME6 horz out and 6CL3 damper look good. HV measure below 25kv, actually about 21 KV...picture does not bloom and from dark (no raster) to full bright, regulation is solid....
My field service guide mentions an R118 1.4 meg resistor, but no HV control. Any ideas?
Horz current is at 207 ma...right near the 210 limit at nominal line voltage.

rca2000
05-12-2016, 12:32 AM
I would make sure your HV probe was working right first..before you go much farther !! If you have a good pix, color and it is steady with no blooming....it has to be pretty close to normal. and 207MA is pretty good...for H-out current too...

zeno
05-12-2016, 09:00 AM
Almost anything lowering the HV should cause the
h. out current to go up. It can be hard to get it under spec
as it is on many sets since they are run at the edge.
Only other thing is if there is a filament resistor for the
3A3 under the socket. Meter is also suspect. Try on
a newer set thats solid state & better regulated.

73 Zeno:smoke:

wabr101
05-12-2016, 12:22 PM
The probe is a new Fluke 40 kv probe and the meter...army surplus...the 627...however...Im sure....even when these were made they werent using DMM......maybe....a VTVM with probe...most people seem to use the meter within the probe type meters.
A solid state set would be a good way to check it. Thank you.

zeno
05-12-2016, 04:52 PM
Try it on the focus pin should be around 6 KV

73 Zeno