View Full Version : Trash Find: Vizio VL370M


Solid_State
06-05-2013, 11:55 PM
Today I found another LCD Flat Panel TV in the trash
The TV is a Vizio VL370M (http://store.vizio.com/vl370m-free-shipping.html) Of course it does not work but the screen is intact and in excellent condition, The frame is also in excellent condition.

When I plugged it in the Vizio symbol lights up Yellow and when I attempt to power on the TV the Vizio symbol will turn white and the screen will light up and then nothing (No Picture or sound or menus) The TV will stay on in that state until either unplugged or I press the power button again

I have not even removed the back yet so I have not looked for bad or bulging capacitors. I will take the back off tomorrow evening to get a better look for an obvious burned or bad part

Anyway in the meantime does anyone have an idea of what could be the problem board inside the Television.

Thanks

PS: I usually hang out at AudioKarma so that's why my post count is so low
My name is the same at AK (Solid_State)

mstaton
06-06-2013, 12:08 AM
More than likely the main board. Check the fuses on that board first. Voltage regulators are another issue, usually U33.

Solid_State
06-06-2013, 12:10 AM
Thanks I take it the voltage regulators will be on the power supply board?

mstaton
06-06-2013, 12:42 AM
main board

rcaman
06-06-2013, 03:17 AM
going to be a bad eeprom on that set.

mstaton
06-06-2013, 12:59 PM
If you dont want to try and fix the board, I found them on Ebay for $40 or best offer. It's a 1080P set worth fixing.
http://www.ebay.com/itm/Vizio-3637-0482-0150-Main-Board-for-VL370M-/281115234066?pt=US_TV_Boards_Parts_Components&hash=item4173c60f12

Solid_State
06-06-2013, 07:06 PM
OK the numbers on the main board are:

Printed on a sticker
3637-0552-0150(5E)
0KM4049AQ14155E
CSD:3637-0552-0395

Written on the board in white text
0171-2271-2855

All of the boards look the same but I take it I have to order this exact board with the same numbers on it for it to work correctly?

Solid_State
06-14-2013, 05:47 PM
OK the numbers on the main board are:

Printed on a sticker
3637-0552-0150(5E)
0KM4049AQ14155E
CSD:3637-0552-0395

Written on the board in white text
0171-2271-2855

All of the boards look the same but I take it I have to order this exact board with the same numbers on it for it to work correctly?

OK so I purchased a new motherboard with the same numbers and it still has the same problems :tears:
Can the LCD controller (T-Con) be bad?
or is this television set a lost cau$e?
Thanks

mstaton
06-14-2013, 11:24 PM
Maybe the board you bought is bad. Very common problem

Solid_State
06-14-2013, 11:59 PM
Maybe the board you bought is bad. Very common problem



The T-Con board is definitely burnt out as there is black marks on the TV chassis and the metal cover that was over the board and it smells of burnt electronics

mstaton
06-15-2013, 12:26 AM
probably should replace that also